using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([&$\+,:;=\?@#\s<>\[\]\{\}[\/]|\\\^%])+";
string input = @"this pat#h%•¶%{has}[many]\inv[alid∑¡™/£¢∞§¶•ª{º!“‘?÷@≠«;–˚$∆ß,Ω µc+ha?ra&cters
this-ªº“‘÷≠-is-a-到英语-good-url.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}