$re = '/([&$\+,:;=\?@#\s<>\[\]\{\}[\/]|\\\\\^%])+/m';
$str = 'this pat#h%•¶%{has}[many]\\inv[alid∑¡™/£¢∞§¶•ª{º!“‘?÷@≠«;–˚$∆ß,Ω µc+ha?ra&cters
this-ªº“‘÷≠-is-a-到英语-good-url.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);