#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[+·`\-::]*?([\u4e00-\u9fa5]+)[+\-十](\d+([.::]\d){0,2})(%|0/0|0\|0|010)?"
Local $sString = "·暴击伤害+21.2%" & @CRLF & _
"·元素精通+11" & @CRLF & _
"暴击率+17.1%" & @CRLF & _
"+攻击力+20" & @CRLF & _
"·防御力+98" & @CRLF & _
"`防御力+21.7%" & @CRLF & _
"`生命值+2147" & @CRLF & _
"-攻击力+15.70/0" & @CRLF & _
"·暴击率+3:9%" & @CRLF & _
"防御力+31:0%" & @CRLF & _
"暴击伤害+46.6010"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")