use strict;
my $str = '·暴击伤害+21.2%
·元素精通+11
暴击率+17.1%
+攻击力+20
·防御力+98
`防御力+21.7%
`生命值+2147
-攻击力+15.70/0
·暴击率+3:9%
防御力+31:0%
暴击伤害+46.6010';
my $regex = qr/[+·`\-::]*?([\u4e00-\u9fa5]+)[+\-十](\d+([.::]\d){0,2})(%|0/0|0\|0|010)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}