const regex = /(?:\/([a-z]{2})(?:\/([a-z]{2}_[A-Z]{2}))?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/([a-z]{2})(?:\\\/([a-z]{2}_[A-Z]{2}))?)', 'g')
const str = `test.com/en
test.com/en/en_US
test.com/es
test.com/es/es_ES
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}