import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^a-z\\n]*[a-z])[A-Za-z._-]*[0-9][A-Za-z0-9._-]*$";
final String string = "ram123-.\n"
+ "r_m-12.m\n"
+ ".--ram123\n"
+ "ram123.-_.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}