re = /^(?=[^a-z\n]*[a-z])[A-Za-z._-]*[0-9][A-Za-z0-9._-]*$/m
str = 'ram123-.
r_m-12.m
.--ram123
ram123.-_.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end