const regex = /^(?=[^a-z\n]*[a-z])[A-Za-z._-]*[0-9][A-Za-z0-9._-]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[^a-z\\n]*[a-z])[A-Za-z._-]*[0-9][A-Za-z0-9._-]*$', 'gm')
const str = `ram123-.
r_m-12.m
.--ram123
ram123.-_.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}