const regex = /(?:^\h*C\h+|\G(?!^))\h*,*\h*\K\d+/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\h*C\\h+|\\G(?!^))\\h*,*\\h*\\K\\d+', 'gim')
const str = `1,2 , 4,5
d 12456, 9890
C 1,13,7,2,55`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}