$re = '/(?:^\h*C\h+|\G(?!^))\h*,*\h*\K\d+/im';
$str = '1,2 , 4,5
d 12456, 9890
C 1,13,7,2,55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);