re = /(?:^\h*C\h+|\G(?!^))\h*,*\h*\K\d+/im
str = '1,2 , 4,5
d 12456, 9890
C 1,13,7,2,55'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end