#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,5}(\.\d{1,2})?$"
Local $sString = "1" & @CRLF & _
"1.1" & @CRLF & _
"11" & @CRLF & _
"11.11" & @CRLF & _
"111" & @CRLF & _
"1111" & @CRLF & _
"11111" & @CRLF & _
"99999" & @CRLF & _
"100000" & @CRLF & _
"99999.99" & @CRLF & _
"100000.0" & @CRLF & _
"100000.0" & @CRLF & _
"999999" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")