import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,5}(\\.\\d{1,2})?$";
final String string = "1\n"
+ "1.1\n"
+ "11\n"
+ "11.11\n"
+ "111\n"
+ "1111\n"
+ "11111\n"
+ "99999\n"
+ "100000\n"
+ "99999.99\n"
+ "100000.0\n"
+ "100000.0\n"
+ "999999\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}