$re = '/^\d{1,5}(\.\d{1,2})?$/m';
$str = '1
1.1
11
11.11
111
1111
11111
99999
100000
99999.99
100000.0
100000.0
999999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);