$re = '/<[^>]+>/m';
$str = '<hello> don\'t remove me <remove me>';
$subst = "<>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;