#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^\(\'\w+\'\,\s|\))"
Local $sString = "('InformationQueue_01_0000002a_03', [{'SystemTimeStr': '2000-00-00 00:00:00.0000', 'CHID': [], 'CHState': [], 'CHPower': [], 'CHTime': [], 'CHTimeModify': [], 'CHWaveModify': [], 'CHWaveCycle': [], 'CHlon': [], 'CHlat': [], 'CHalt': [], 'LocationType': '00', 'lat': 0.0, 'lon': 0.0, 'alt': 0.0, 'headerFlag': 'a0a1', 'loadLen': 34, 'BCCCheck': '8d', 'version': '01', 'deviceID': '0000002a', 'deviceType': '01', 'messageID': '03', 'header': 'a0a100228d010000002a0103', 'message': '07d00000000000000000000000017c2aa5a800000000000000000000000000000000'}]) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")