const regex = /(^\(\'\w+\'\,\s|\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\(\\\'\\w+\\\'\\,\\s|\\))', 'gm')
const str = `('InformationQueue_01_0000002a_03', [{'SystemTimeStr': '2000-00-00 00:00:00.0000', 'CHID': [], 'CHState': [], 'CHPower': [], 'CHTime': [], 'CHTimeModify': [], 'CHWaveModify': [], 'CHWaveCycle': [], 'CHlon': [], 'CHlat': [], 'CHalt': [], 'LocationType': '00', 'lat': 0.0, 'lon': 0.0, 'alt': 0.0, 'headerFlag': 'a0a1', 'loadLen': 34, 'BCCCheck': '8d', 'version': '01', 'deviceID': '0000002a', 'deviceType': '01', 'messageID': '03', 'header': 'a0a100228d010000002a0103', 'message': '07d00000000000000000000000017c2aa5a800000000000000000000000000000000'}]) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}