use strict;
my $str = '(\'InformationQueue_01_0000002a_03\', [{\'SystemTimeStr\': \'2000-00-00 00:00:00.0000\', \'CHID\': [], \'CHState\': [], \'CHPower\': [], \'CHTime\': [], \'CHTimeModify\': [], \'CHWaveModify\': [], \'CHWaveCycle\': [], \'CHlon\': [], \'CHlat\': [], \'CHalt\': [], \'LocationType\': \'00\', \'lat\': 0.0, \'lon\': 0.0, \'alt\': 0.0, \'headerFlag\': \'a0a1\', \'loadLen\': 34, \'BCCCheck\': \'8d\', \'version\': \'01\', \'deviceID\': \'0000002a\', \'deviceType\': \'01\', \'messageID\': \'03\', \'header\': \'a0a100228d010000002a0103\', \'message\': \'07d00000000000000000000000017c2aa5a800000000000000000000000000000000\'}]) ';
my $regex = qr/(^\(\'\w+\'\,\s|\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}