import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:)?(?:\\/\\/)?(?:[^@\\n]+@)?(?:www\\.)?([^:\\/\\n]+)";
final String string = "https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22\n"
+ "http://mplay.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://lplay.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://play.google.co.in/sadfask/asdkfals?dk=10\n"
+ "http://tplay.google.co.in/sadfask/asdkfals?dk=10?\n"
+ "http://www.google.co.in:/sadfask/asdkfals?dk=10\n"
+ "www.google.co.in/sadfask/asdkfals?dk=10\n"
+ "https://user:pass@google.com/?a=b#asdd\n"
+ "//mplay.google.co.in\n\n\n"
+ "-- Regular expression ^(?:https?:)?(?:\\/\\/)?(?:[^@\\n]+@)?(?:www\\.)?([^:\\/\\n]+)\n"
+ "-- used below extracts domain with subdomains out of a full url.\n"
+ "-- It skips protocol (ex: https:), \"//\", \"@\", www subdomain and\n"
+ "-- then captures everything (ex: domain) before \":\" or \"/\" or end of line.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}