const regex = new RegExp('^(?:https?:)?(?:\\/\\/)?(?:[^@\\n]+@)?(?:www\\.)?([^:\\/\\n]+)', 'gm')
const str = `https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22
http://mplay.google.co.in/sadfask/asdkfals?dk=10
http://lplay.google.co.in/sadfask/asdkfals?dk=10
http://play.google.co.in/sadfask/asdkfals?dk=10
http://tplay.google.co.in/sadfask/asdkfals?dk=10?
http://www.google.co.in:/sadfask/asdkfals?dk=10
www.google.co.in/sadfask/asdkfals?dk=10
https://user:pass@google.com/?a=b#asdd
//mplay.google.co.in
-- Regular expression ^(?:https?:)?(?:\\/\\/)?(?:[^@\\n]+@)?(?:www\\.)?([^:\\/\\n]+)
-- used below extracts domain with subdomains out of a full url.
-- It skips protocol (ex: https:), "//", "@", www subdomain and
-- then captures everything (ex: domain) before ":" or "/" or end of line.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}