// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?:)?(?:\/\/)?(?:[^@\n]+@)?(?:www\.)?([^:\/\n]+)").unwrap();
let string = "https://play.google.com/store/apps/details?id=com.skgames.trafficracer%22
http://mplay.google.co.in/sadfask/asdkfals?dk=10
http://lplay.google.co.in/sadfask/asdkfals?dk=10
http://play.google.co.in/sadfask/asdkfals?dk=10
http://tplay.google.co.in/sadfask/asdkfals?dk=10?
http://www.google.co.in:/sadfask/asdkfals?dk=10
www.google.co.in/sadfask/asdkfals?dk=10
https://user:pass@google.com/?a=b#asdd
//mplay.google.co.in
-- Regular expression ^(?:https?:)?(?:\\/\\/)?(?:[^@\\n]+@)?(?:www\\.)?([^:\\/\\n]+)
-- used below extracts domain with subdomains out of a full url.
-- It skips protocol (ex: https:), \"//\", \"@\", www subdomain and
-- then captures everything (ex: domain) before \":\" or \"/\" or end of line.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}