import re
regex = re.compile(r'[\w\s]+>(\d{1,2})<')
test_str = ("818y1873+130I have some text here09 124i10029102lsdgn2in3>31<\n"
"mkm1ikm12klni12m4j12??=?!=I\"=and then some text heremsiJR310>39<0MK)==!)=\"!")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")