using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(foo|bar)\s((?:[a-zA-Z0-9'.-]{1,7}\s){1,5}\w{1,7}\s?)(?<!['.-])$";
string input = @"bar Brian M. O''Dan Darwin";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}