import re
regex = re.compile(r"^(foo|bar)\s((?:[a-zA-Z0-9'.-]{1,7}\s){1,5}\w{1,7}\s?)(?<!['.-])$", flags=re.IGNORECASE)
test_str = "bar Brian M. O''Dan Darwin"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")