$re = '/\w+.\w+$/m';
$str = 'C:\\Users\\owner_pc3\\Desktop\\labo\\output\\test.psd
^.*\\\\
\\w+.\\w+$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);