re = /\w+.\w+$/m
str = 'C:\\Users\\owner_pc3\\Desktop\\labo\\output\\test.psd
^.*\\\\
\\w+.\\w+$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end