#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!$)(?:(\d+)h)?(?:(\d+)m)?(?:(\d+)s)?$"
Local $sString = "11h22m33s + 08:00" & @CRLF & _
"08:00 + 11h22m" & @CRLF & _
"11h33s" & @CRLF & _
"22m33s" & @CRLF & _
"11h" & @CRLF & _
"22m" & @CRLF & _
"33s"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")