re = /^(?!$)(?:(\d+)h)?(?:(\d+)m)?(?:(\d+)s)?$/m
str = '11h22m33s + 08:00
08:00 + 11h22m
11h33s
22m33s
11h
22m
33s'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end