$re = '/^(?!$)(?:(\d+)h)?(?:(\d+)m)?(?:(\d+)s)?$/m';
$str = '11h22m33s + 08:00
08:00 + 11h22m
11h33s
22m33s
11h
22m
33s';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);