import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]+|[A-Z]?[a-z]+)(?=[A-Z]|\\b)";
final String string = "eclipseRCPExt\n"
+ "SomethingIsWrittenHere\n"
+ "TEXTIsWrittenHERE\n"
+ "VALUE\n"
+ "loremIpsum";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}