$re = '/([A-Z]+|[A-Z]?[a-z]+)(?=[A-Z]|\b)/';
$str = 'eclipseRCPExt
SomethingIsWrittenHere
TEXTIsWrittenHERE
VALUE
loremIpsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);