re = /([A-Z]+|[A-Z]?[a-z]+)(?=[A-Z]|\b)/
str = 'eclipseRCPExt
SomethingIsWrittenHere
TEXTIsWrittenHERE
VALUE
loremIpsum'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end