#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " .*"
Local $sString = "my string is sad"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)