use strict;
my $str = 'my string is sad';
my $regex = qr/ .*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";