using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$";
string input = @"02_AUT_M_PHY M-2015-12
02_GASPOOL_H_M_PHY M-2015-12
02_GASPOOL_L_M_PHY M-2015-12
02_NBP_H_M_PHY M-2015-12
02_MGP_M_PHY M-2015-12
02_NCG_H_M_PHY M-2015-12
02_NCG_L_M_PHY M-2015-12
02_OTE_M1_PHY M-2015-12
02_POLVP_M2_PHY M-2015-12
02_PEGN_M3_PHY M-2015-12
02_SVKVP_M4_PHY M-2015-12
02_ZEEBRUGGE_H_M5_PHY M-2015-12
02_ZTP_H_M10_PHY M-2015-12
02_ZTP_L_M99_PHY M-2015-12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}