// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$").unwrap();
let string = "02_AUT_M_PHY M-2015-12
02_GASPOOL_H_M_PHY M-2015-12
02_GASPOOL_L_M_PHY M-2015-12
02_NBP_H_M_PHY M-2015-12
02_MGP_M_PHY M-2015-12
02_NCG_H_M_PHY M-2015-12
02_NCG_L_M_PHY M-2015-12
02_OTE_M1_PHY M-2015-12
02_POLVP_M2_PHY M-2015-12
02_PEGN_M3_PHY M-2015-12
02_SVKVP_M4_PHY M-2015-12
02_ZEEBRUGGE_H_M5_PHY M-2015-12
02_ZTP_H_M10_PHY M-2015-12
02_ZTP_L_M99_PHY M-2015-12";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}