const regex = /^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'M)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'M)-(?'year'\d{4})-\b(?'month'0[1-9]|1[0-2])\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?\'commodity\'02)_(?\'market\'\\w{3,})_(?\'tenortype\'M)(?\'offset\'[1-9][0-9]?)?_(?\'derivative\'PHY|FUT) (?\'period\'M)-(?\'year\'\\d{4})-\\b(?\'month\'0[1-9]|1[0-2])\\b$', 'gm')
const str = `02_AUT_M_PHY M-2015-12
02_GASPOOL_H_M_PHY M-2015-12
02_GASPOOL_L_M_PHY M-2015-12
02_NBP_H_M_PHY M-2015-12
02_MGP_M_PHY M-2015-12
02_NCG_H_M_PHY M-2015-12
02_NCG_L_M_PHY M-2015-12
02_OTE_M1_PHY M-2015-12
02_POLVP_M2_PHY M-2015-12
02_PEGN_M3_PHY M-2015-12
02_SVKVP_M4_PHY M-2015-12
02_ZEEBRUGGE_H_M5_PHY M-2015-12
02_ZTP_H_M10_PHY M-2015-12
02_ZTP_L_M99_PHY M-2015-12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}