import re
regex = re.compile(r"(?<!\d)-?\d+(?:\.\d+)?|\D", flags=re.MULTILINE)
test_str = ("-99+44+2+-3/3.2-6\n"
"31+2--3*43.8/1%(1*2)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")