import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{.*?\\}(?<!\\}\\}),\\r?\\n(?=Pagination\\b)";
final String string = "@jurisdiction{InternationalFruit:1972fo,\n"
+ "Abstract = {{Text with all kinds of punctuation.?},\n"
+ "Pagination = {paragraph},\n"
+ "Ecli = {EU:C:1972:115},\n"
+ "Keywords = {eu},\n"
+ "Number = {5},\n"
+ "Title = {{International Fruit Company NV}},\n"
+ "Year = {1972}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}