$re = '/\{\{.*?\}(?<!\}\}),\r?\n(?=Pagination\b)/m';
$str = '@jurisdiction{InternationalFruit:1972fo,
Abstract = {{Text with all kinds of punctuation.?},
Pagination = {paragraph},
Ecli = {EU:C:1972:115},
Keywords = {eu},
Number = {5},
Title = {{International Fruit Company NV}},
Year = {1972}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);