import re
regex = re.compile(r"\{\{.*?\}(?<!\}\}),\r?\n(?=Pagination\b)", flags=re.MULTILINE)
test_str = ("@jurisdiction{InternationalFruit:1972fo,\n"
"Abstract = {{Text with all kinds of punctuation.?},\n"
"Pagination = {paragraph},\n"
"Ecli = {EU:C:1972:115},\n"
"Keywords = {eu},\n"
"Number = {5},\n"
"Title = {{International Fruit Company NV}},\n"
"Year = {1972}}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")