#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:^RAP [\d.\d]+ .+){1}(?:\n^[a-zA-Z0-9].+)+)"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
"Modelo Educativo Centrado en el Aprendizaje con Enfoque por Competencias Plan 2008 Página 5 de 20 " & @CRLF & _
" " & @CRLF & _
"Carrera: TÉCNICO EN PROGRAMACIÓN Unidad de Aprendizaje: BASES DE DATOS " & @CRLF & _
" " & @CRLF & _
"RED DE COMPETENCIAS (GENERAL Y PARTICULARES) " & @CRLF & _
" " & @CRLF & _
"Competencia particular 2 " & @CRLF & _
" " & @CRLF & _
"Utiliza gestores y lenguajes de " & @CRLF & _
"bases de datos para la gestión y " & @CRLF & _
"manipulación de la información de " & @CRLF & _
"las bases datos. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Competencia particular 3 " & @CRLF & _
" " & @CRLF & _
"Aplica protección a las bases de " & @CRLF & _
"datos para su confidencialidad, " & @CRLF & _
"disponibilidad e integridad. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Competencia General " & @CRLF & _
"Desarrolla bases de datos normalizadas e implementando políticas de seguridad con gestores " & @CRLF & _
"de bases de datos para la explotación de la información a través de lenguajes consulta a base " & @CRLF & _
"de datos. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"RAP 2.2 Utilizan lenguajes de acceso a " & @CRLF & _
"bases de datos para la manipulación de " & @CRLF & _
"la información contenida en las Bases " & @CRLF & _
"de Datos. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"RAP 2.1 Utiliza gestores de bases de " & @CRLF & _
"datos para la administración de las " & @CRLF & _
"bases de datos. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"RAP 3.2 Aplica transacciones para " & @CRLF & _
"asegurar la autenticidad de la " & @CRLF & _
"información para asegurar su " & @CRLF & _
"confiabilidad. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"RAP 3.1 Aplica protección al acceso de " & @CRLF & _
"los datos para mantener su privacidad. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"Competencia particular 1 " & @CRLF & _
" " & @CRLF & _
"Diseña Bases de Datos " & @CRLF & _
"normalizadas aplicando el " & @CRLF & _
"modelado de datos Entidad-" & @CRLF & _
"Relación y Relacional para genera" & @CRLF & _
"el esquema conceptual y lógico." & @CRLF & _
"RAP 1.1 Contextualiza los conceptos " & @CRLF & _
"fundamentales de Bases de Datos. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"RAP 1.2 Contextualiza los diferentes " & @CRLF & _
"Modelos de datos utilizados para el " & @CRLF & _
"diseño de Bases de Datos. " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
"RAP 1.3 Modela bases de datos " & @CRLF & _
"normalizadas aplicando las " & @CRLF & _
"metodologías de desarrollo del " & @CRLF & _
"esquema conceptual y lógico. " & @CRLF & _
" " & @CRLF & _
" "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")