import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^RAP [\\d.\\d]+ .+){1}(?:\\n^[a-zA-Z0-9].+)+)";
final String string = "\n"
+ " \n"
+ "Modelo Educativo Centrado en el Aprendizaje con Enfoque por Competencias Plan 2008 Página 5 de 20 \n"
+ " \n"
+ "Carrera: TÉCNICO EN PROGRAMACIÓN Unidad de Aprendizaje: BASES DE DATOS \n"
+ " \n"
+ "RED DE COMPETENCIAS (GENERAL Y PARTICULARES) \n"
+ " \n"
+ "Competencia particular 2 \n"
+ " \n"
+ "Utiliza gestores y lenguajes de \n"
+ "bases de datos para la gestión y \n"
+ "manipulación de la información de \n"
+ "las bases datos. \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ "Competencia particular 3 \n"
+ " \n"
+ "Aplica protección a las bases de \n"
+ "datos para su confidencialidad, \n"
+ "disponibilidad e integridad. \n"
+ " \n"
+ " \n"
+ " \n"
+ "Competencia General \n"
+ "Desarrolla bases de datos normalizadas e implementando políticas de seguridad con gestores \n"
+ "de bases de datos para la explotación de la información a través de lenguajes consulta a base \n"
+ "de datos. \n"
+ " \n"
+ " \n"
+ "RAP 2.2 Utilizan lenguajes de acceso a \n"
+ "bases de datos para la manipulación de \n"
+ "la información contenida en las Bases \n"
+ "de Datos. \n"
+ " \n"
+ " \n"
+ "RAP 2.1 Utiliza gestores de bases de \n"
+ "datos para la administración de las \n"
+ "bases de datos. \n"
+ " \n"
+ " \n"
+ "RAP 3.2 Aplica transacciones para \n"
+ "asegurar la autenticidad de la \n"
+ "información para asegurar su \n"
+ "confiabilidad. \n"
+ " \n"
+ " \n"
+ "RAP 3.1 Aplica protección al acceso de \n"
+ "los datos para mantener su privacidad. \n"
+ " \n"
+ " \n"
+ "Competencia particular 1 \n"
+ " \n"
+ "Diseña Bases de Datos \n"
+ "normalizadas aplicando el \n"
+ "modelado de datos Entidad-\n"
+ "Relación y Relacional para genera\n"
+ "el esquema conceptual y lógico.\n"
+ "RAP 1.1 Contextualiza los conceptos \n"
+ "fundamentales de Bases de Datos. \n"
+ " \n"
+ " \n"
+ "RAP 1.2 Contextualiza los diferentes \n"
+ "Modelos de datos utilizados para el \n"
+ "diseño de Bases de Datos. \n"
+ " \n"
+ " \n"
+ "RAP 1.3 Modela bases de datos \n"
+ "normalizadas aplicando las \n"
+ "metodologías de desarrollo del \n"
+ "esquema conceptual y lógico. \n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}