use strict;
my $str = '12v some, Item, which contains comma, Another item';
my $regex = qr/\s*,(?!\s*\p{Ll})\s*/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";