re = /\s*,(?!\s*\p{Ll})\s*/m
str = '12v some, Item, which contains comma, Another item'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result