$re = '/\s*,(?!\s*\p{Ll})\s*/m';
$str = '12v some, Item, which contains comma, Another item';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;