package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\p{N}+\s+(?:an|year|سنة)s?`)
var str = `"I'm 24 years old" "J'ai 25 ans" "I have 25 year" "عندي ٢٣ سنة "`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}