// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b\p{N}+\s+(?:an|year|سنة)s?").unwrap();
let string = "\"I'm 24 years old\" \"J'ai 25 ans\" \"I have 25 year\" \"عندي ٢٣ سنة \"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}