using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(EXT|GEN)_CODE\d{1,3}=";
string input = @"EXT_CODE5=PC099|EXT_CODE22=BC054|EXT_CODE4=ZC018|GEN_CODE11=ZV010";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}