package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(EXT|GEN)_CODE\d{1,3}=`)
var str = `EXT_CODE5=PC099|EXT_CODE22=BC054|EXT_CODE4=ZC018|GEN_CODE11=ZV010`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}